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Copyright
Copyright © 2000−2007 InsiTech, Inc. All Rights Reserved.

Restricted Rights Legend

This software and documentation is subject to and made available only pursuant to the terms of the InsiTech,
Inc. End−User License Agreement (EULA) and may be used or copied only in accordance with the terms of
that agreement. It is against the law to copy the software except as specifically allowed in the agreement. This
document may not, in whole or in part, be copied photocopied, reproduced, translated, or reduced to any
electronic medium or machine readable form without prior consent, in writing, from InsiTech, Inc.

Use, duplication or disclosure by the U.S. Government is subject to restrictions set forth in the InsiTech, Inc.
EULA and in subparagraph (c)(1) of the Commercial Computer Software−Restricted Rights Clause at FAR
52.227−19; subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software Clause at DFARS
252.227−7013; subparagraph (d) of the Commercial Computer Software−Licensing clause at NASA FAR
supplement 16−52.227−86; or the equivalent.

Information in this document is subject to change without notice and does not represent a commitment on the
part of InsiTech, Inc. THE SOFTWARE AND DOCUMENTATION ARE PROVIDED "AS IS" WITHOUT
WARRANTY OF ANY KIND INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. FURTHER, INSITECH, INC.
DOES NOT WARRANT, GUARANTEE, OR MAKE ANY REPRESENTATIONS REGARDING THE
USE, OR THE RESULTS OF THE USE, OF THE SOFTWARE OR WRITTEN MATERIAL IN TERMS OF
CORRECTNESS, ACCURACY, RELIABILITY, OR OTHERWISE.

Trademarks or Service Marks

XTT, XTTC, XTTS are trademarks of InsiTech, Inc.

XTT − Copyright © 2000−2007 InsiTech Inc. All rights reserved. Patent pending.• 
Java API for XML Processing (JAXP 1.1) − Copyright © 1995−2001 Sun Microsystems, Inc.• 
Apache Tomcat − Apache is a trademark of The Apache Software Foundation, and is used with
permission.

• 

kXML − Open source parser hosted at kxml.org. Available under the GNU Public License (GPL),
V2.0.

• 

Hypersonic SQL (HSQLDB) − Copyright (c) 1995−2000 by the Hypersonic SQL Group. All rights
reserved. Please refer to the EULA ("software license agreement.txt" found in your InsiTech
installation folder) for full legal details concerning usage of this product.

• 

All other product names may be trademarks of the respective companies with which they are
associated.

• 
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Important: How to Use This Setup Guide
This Setup Guide will guide you through the installation of XTT v 5.9.4 in one of the following IDEs:

NetBeans IDE 6.0 (with Web &Java EE Bundle)• 
Eclipse 3.3 SDK with WTP 2.0• 
Eclipse 3.2 SDK with WTP 1.5• 

This guide describes how to:

Install XTT v 5.9.4 in NetBeans or Eclipse• 
Open a sample project workspace called xtt−examples• 
Build and deploy the xtt−examples web application to the bundled Tomcat servlet container.• 

Once your setup is complete, please read the Developer Guide (in the XTT documentation integrated in the
help system of your IDE) in order to:

Understand how to work with the xtt−examples workspace• 
Explore the examples and published source code in the xtt−examples workspace• 
Learn how set up a new XTT project workspace for your own application• 
Configure XTT so that it can interface with JDBC or Object Persistence Layer data sources• 

Note: This Setup Guide is provided as an independent .pdf file to be used as reference when first installing
XTT. After installing XTT, all the other XTT documentation referred to in this Guide becomes available
through the IDE's help/documentation system (under the menu: Help > Help Contents > XTT 5.9.4 Help).

Conventions used in this Guide

{XTT home}: This refers to the root folder of the unzipped XTT downloads. If you are unzipping to
C:, then {XTT home} refers to the directory C:/InsiTech/XTT−5.9.4.

• 

Getting Further Assistance

To get free assistance installing XTT, please email InsiTech support at support@itgp.com.
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Prerequisites

Software Requirements

Developing with XTT v 5.9.4 requires one of the following IDEs:

IDE
Requirements

Additional Requirements

Design time Run time

NetBeans 6.0
JDK 6.0 Update 2 or higher1 JRE 1.4

Eclipse 3.3
with WTP 2.0

JDK 6.0 Update 2 or higher2

Instantiations Designer3 v 6.4.1
or above

JRE 1.4

Eclipse 3.2
with WTP 1.5

JDK 6.0 Update 2 or higher2

Instantiations Designer3 v 6.4.1
or above

JRE 1.4

Note 1: Java 6.0 is recommended for GUI development in NetBeans due to a white−on−white text annoyance
occuring the bean object trees in the XTT Object Wizards and tools with Java 5.0.

Note 2: Java 6.0 is recommended for GUI development in Eclipse due to occasional freezing observed when
using customizers with Java 5.0.

Note 3: Instantiations Designer (WindowBuilderPro) is recommended for GUI development in Eclipse,
Although other GUI builders for Eclipse exist, InsiTech is not capable of supporting them due to their missing
features and outstanding open bugs.

Abbreviations used in this document

All the abbreviations described in the documentation are defined in the Getting Started Guide.

Data sources and types contained in the examples workspace
for the initial install

Relational
Database

The xtt−examples workspace uses HSQLDB for its database . This
open source database can be found at: http://hsqldb.sourceforge.net.

Limitations of an unlicensed XTT Server

Unless licensed, an XTT Server permits only one concurrent connection from one user. Other than this
limitation, an unlicensed XTT Server offers all the functionality of a licensed XTT Server.

For additional details on these limitations, please refer to the Developer Guide.
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Installing XTT in NetBeans
Note 1: XTT v 5.9.4 for NetBeans is specifically designed to work with the NetBeans version 6.0. Older
NetBeans versions are not supported.

Note 2: After installing the XTT v 5.9.4 modules inside NetBeans, any existing XTT workspace created prior
to XTT v 5.8.0 will need to be migrated. Please refer to Appendix C: Migrating existing workspaces in
NetBeans for more details.

Note 3: If you plan to use web XTT Web Services, make sure that your NetBeans has enough memory.
Memory setting for NetBeans live in \NetBeans 6.0\etc\netbeans.conf file. These JVM switches are: −J−Xmx,
−J−XX:PermSize and −J−XX:MaxPermSize. Settings that we like to use are −J−Xmx256m,
−J−XX:PermSize=32m and −J−XX:MaxPermSize=192m. For a complete discussion of this topic visit:
http://performance.netbeans.org/howto/jvmswitches/index.html.

Install the XTT modules for NetBeans

There are three paths to installing the latest XTT modules in your IDE:

Offline new installation of the XTT modules downloaded from
http://www.insitechinc.com/download.php3

• 

Online new installation of the XTT modules via the NetBeans 3rd Party Plugins Update Center• 
Online updates to update older modules via the XTT Update Center• 

Offline installation via XTT downloads

Install NetBeans IDE 6.0. Download the Web &Java EE (or All) NetBeans IDE Download Bundle
from http://www.netbeans.org. Install NetBeans on your computer.

1. 

Download the XTT modules for NetBeans from http://www.insitechinc.com/download.php3. You
need three XTT modules.

The XTT core module♦ 
The XTT support module♦ 
The XTT third−party module♦ 

2. 

Run the NetBeans IDE. Select Tools > Plugins.3. 
Click on the Downloaded tab.4. 
Click on Add Plugins.... Browse to the XTT modules that you downloaded in the earlier step. Add all
of the XTT modules to the downloaded tab list.

5. 

Verify the check box is checked for each XTT module listed. Click on Install. Then, click on Next.6. 
Accept the License Agreement by clicking on the text starting with I accept .... Then, click on Install.7. 
Wait for the modules to be validated.

Important Note: You will see a "Validation Warning" suggesting that the XTT modules are
"untrusted". This warning is a bug in NetBeans. The XTT modules are duly signed using a certificate
issued by Thawte to InsiTech, Inc. The modules themselves are based at http://www.insitechinc.com.
Simply examine the certificate to verify this is the case, and proceed with the installation.

Click Continue.

8. 

Wait for the modules to be installed. Click on Finish to complete the module installation.9. 
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After installing XTT, a window will be opened providing you a link to download the XTT sample workspaces
for Netbeans described in the section below.

Online installation via the 3rd Party Plugins Update Center

Install NetBeans IDE 6.0. Download the Web &Java EE (or All) NetBeans IDE Download Bundle
from http://www.netbeans.org. Install NetBeans on your computer.

1. 

Run the NetBeans IDE. Select Tools > Plugins.2. 
Click on the Settings tab. Verify that the check box is checked for 3rd Party Plugins.3. 
Click on the Available Plugins tab. The following XTT modules should be available:

The XTT core module♦ 
The XTT support module♦ 
The XTT third−party module♦ 

4. 

Verify the check box is checked for each XTT module listed. Click on Install. Then, click on Next.5. 
Accept the License Agreement by clicking on the text starting with I accept .... Then, click on Install.6. 
Wait for the modules to be validated.

Important Note: You will see a "Validation Warning" suggesting that the XTT modules are
"untrusted". This warning is a bug in NetBeans. The XTT modules are duly signed using a certificate
issued by Thawte to InsiTech, Inc. The modules themselves are based at http://www.insitechinc.com.
Simply examine the certificate to verify this is the case, and proceed with the installation.

Click Continue.

7. 

Wait for the modules to be installed. Click on Finish to complete the module installation.8. 

After installing XTT, a window will be opened providing you a link to download the XTT sample workspaces
for Netbeans described in the section below.

Online updates via the XTT Update Center

Run the NetBeans IDE. Select Tools > Plugins.1. 
Click on the Settings tab. Verify that the check box is checked for XTT Update Center.2. 
Click on the Available Plugins tab. Look for the following updatable XTT modules:

The XTT core module♦ 
The XTT support module♦ 
The XTT third−party module♦ 

3. 

Verify the check box is checked for each XTT module listed (if any). Click on Install. Then, click on
Next.

4. 

Accept the License Agreement by clicking on the text starting with I accept .... Then, click on Install.5. 
Wait for the modules to be validated.

Important Note: You will see a "Validation Warning" suggesting that the XTT modules are
"untrusted". This warning is a bug in NetBeans. The XTT modules are duly signed using a certificate
issued by Thawte to InsiTech, Inc. The modules themselves are based at http://www.insitechinc.com.
Simply examine the certificate to verify this is the case, and proceed with the installation.

Click Continue.

6. 

Wait for the modules to be installed. Click on Finish to complete the module installation.7. 

After installing XTT, a window will be opened providing you a link to download the XTT sample workspaces

Setup Guide
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for Netbeans described in the section below.

XTT modules are installed; Now What?

We will use xtt−examples project workspace to demonstrate the capabilities of XTT. Follow the instructions
below.

Download the xtt−examples workspace for NetBeans

If you have installed the XTT module/plugin through NetBeans Update Center Wizard, please follow this link
http://www.insitechinc.com/download.php3 and download the accompanying the xtt−examples project
workspace. It is not contained in the shipped modules.

Unzip the xtt−examples workspace for NetBeans

Once you have installed the XTT modules for NetBeans, download the XTT samples for NetBeans from
http://www.insitechinc.com/download.php3, and unzip it to your file system.

File/Directory Purpose

{XTT home}
The base folder containing the Setup
Guide, readme, and license for XTT 5.9.4

{XTT home}/netbeans−6.0
The base folder for NetBeans−related
examples

{XTT
home}/netbeans−6.0/workspace−xtt−examples

An XTT project workspace containing
selected XTT source code and examples

Open the xtt−examples workspace in the IDE

The XTT Development Kit contains a simple samples application called xtt−examples which we will use to
verify the correct installation of XTT. Please follow the steps below:

Click on File −> Open Project... and browse into {XTT
home}/netbeans−6.0/workspace−xtt−examples directory.

1. 

Select project xtt−examples and xtt−source. Click Open Project Folder.2. 
After Scanning Project Classpaths process is completed you will see six projects in the Project tab;
xtt−examples, xtt−examples−client, xtt−examples−common, xtt−examples−run, xtt−serverside
and xtt−source.

3. 
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Deploy the xtt−examples web application

If you have an XTT Server license file (called XTTS_License.properties), copy that file to
the root of the common classes of your application server (e.g., in Tomcat that would be {Tomcat
home}/common/classes). Refer to your application server's documentation for details where this
directory resides. (Alternately, you may also copy it to the root of the classpath of each of your web
applications. e.g.: {XTT webapp project root}/src/java, however that is not recommended.)

1. 

Click on the Projects tab. Right−click on the xtt−examples project to bring up project context menu.
Select Clean and Build.

2. 

Right−click on the xtt−examples project to bring up project context menu. Select Undeploy and
Deploy.

3. 

To verify that the deployment process was successful, confirm that there were no error messages in
the Output window in the xtt−examples (run−deploy) tab. The Apache Tomcat 6.0.14 Log tab
should indicate that one database connection (CP1) was initialized and that one object connection
(HIBERNATE) was initialized.

4. 
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Test the connection to the xtt−examples web application

Right click on the xtt−examples−client project to bring up project context menu. Select XTT Table View
button ( ).

The XTT Table View Wizard is launched (as shown in the next following). The server address
http://localhost:8084/xtt−examples/XTTS appears in the Server Address text field. Press the Get Table
List button.

Select a table, and then a column. If you see table metadata similar to the picture above, the installation
process was successful.

Next steps

You have successfully completed the setup.

Please consult the Developer Guide (in the NetBeans menu under Help > Help Contents > XTT Help >
Product Documentation > Developer Guide) for further instructions on using the xtt−examples application,
creating your own application and exploring the source code and examples.

If you wish to migrate an existing XTT workspace created prior to XTT v 5.8.0, please refer to Appendix B:
Migrating existing workspaces in NetBeans.

Setup Guide
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Installing XTT in Eclipse
Note 1: XTT v 5.9.4 for Eclipse is specifically designed to work with the Eclipse version 3.2 or 3.3. Other
Eclipse versions are not supported.

Note 2: The Web Tools Platform (WTP) is required to activitate the core XTT plugins. For develoment, the
developer has a choice of deploying webapps using WTP (in WTP−based workspaces) or building webapps
without WTP in Ant−based project workspaces.

Note 3: After installing the XTT v 5.9.4 feature inside Eclipse, any existing XTT workspace created prior to
XTT v 5.8.0 will need to be migrated. Please refer to Appendix B: Migrating existing workspaces in NetBeans
for more details.

Note 4: If you plan to use web XTT Web Services, make sure that your Eclipse has enough memory. By
default, Eclipse will allocate up to 256 megabytes of Java heap memory. This should be ample, but you could
conceivably have to increase this amount to generate code for some web services. Eclipse allows you to pass
arguments directly to the Java VM using the −vmargs command line argument.

eclipse.exe −vmargs −Xms128M −Xmx512M −XX:PermSize=128M −XX:MaxPermSize=256M

where −Xmx value set to greater than "512M" (256 megabytes −− the default). For a complete discussion of
this topic visit:
http://help.eclipse.org/help32/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/running_eclipse.htm

or http://wiki.eclipse.org/FAQ_How_do_I_increase_the_permgen_size_available_to_Eclipse%3F

Install the XTT plugins for Eclipse

There is currently one path to installing the latest XTT plugins in your IDE:

Offline new installation of the XTT plugins downloaded from
http://www.insitechinc.com/download.php3

• 

Offline installation of a downloaded XTT plugins

Install the Eclipse SDK with the Web Tools Platform from
http://download.eclipse.org/webtools/downloads. Choose either:

Eclipse 3.3 SDK with WTP 2.0 − Download the "all−in−one" module.♦ 
Eclipse 3.2 SDK with WTP 1.5 − Download the "all−in−one" module.♦ 

Unzip the downloaded "all−in−one" Eclipse WTP archive into your preferred Eclipse WTP
installation home (e.g. C:\eclipse.)

1. 

Download the Instantiations Swing Designer (WindowBuilderPro) from
http://www.instantiations.com/windowbuilderpro/download.html visual editor plugin. Select the latest
stable build (6.4.1 and above) of the Zip Edition for Eclipse, either 3.2 or 3.3, depending on the
Eclipse version that you have installed. Install the plugin into your Eclipse WTP installation home
(e.g. C:\eclipse.)

2. 

Download the XTT plugins for Eclipse from http://www.insitechinc.com/download.php3. The
plugins are contained in a single zip archive. Install the plugin into your Eclipse WTP installation
home (e.g. C:\eclipse.)

3. 

Start Eclipse and activate Instantiations Designer:4. 
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Open the Preferences window. From the menu bar choose: Window > Preferences. Then
select Designer from the tree.

a. 

On the Designer tab, click on the Registration and Activiation button.b. 
If you have registered serial number and activation key it, enter it. If you do not have a
registered serial number, follow the steps to obtain a free evaluation serial number and
activation key.

c. 

XTT plugins are installed; Now What?

We will use xtt−examples project workspace to demonstrate the capabilities of XTT. The demonstration will
use the WTP−based flavor of the XTT Examples project workspace, and not the Ant−based flavor. (The
Ant−based flavor is also available. Please refer to the Developer's Guide for more information.) Follow the
instructions below.

Download the xtt−examples workspace for Eclipse

Please follow this link http://www.insitechinc.com/download.php3 and download the accompanying the
WTP−based xtt−examples project workspace. It is not contained in the shipped plugins.

Unzip the xtt−examples workspace for Eclipse

Once you have installed the XTT plugins for Eclipse, download the XTT samples for Eclipse from
http://www.insitechinc.com/download.php3, and unzip it to your file system.

File/Directory Purpose

{XTT home}
The base folder containing the Setup
Guide, readme, and license for XTT 5.9.4

{XTT home}/eclipse_wtp
The base folder for Eclipse−related
examples

{XTT
home}/eclipse_wtp/workspace−xtt−examples

An XTT project workspace containing
selected XTT source code and examples

Open the xtt−examples workspace in the IDE

Click on File > Import... Select General > Existing Projects into Workspace. Browse to {XTT
home}/eclipse_wtp/workspace−xtt−examples. Five projects should appear. Make sure

1. 
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all five projects are selected, and that the 'Copy project into workspace' check box is checked. Click
Finish and wait a few moments until the projects are imported and recompiled by Eclipse.

Allow the projects to be built. Important: While the projects are being built, you will see errors and
warnings momentarily appear in the "Problems" pane of the IDE. All errors should be resolved once
the projects are completely built.

2. 

The xtt−examples workspace is now opened and initialized.3. 

Setup Guide
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Prepare the xtt−examples web application for deployment

1. Install the license file

If you have an XTT Server license file (called XTTS_License.properties), copy that file to the root of
the common classes of your application server (e.g., in Tomcat that would be {Tomcat
home}/common/classes). If you use the XTT defined Tomcat, you can find it in eclipse's plugins
directory under com.itgp.eclipse.tomcat_1.0.0 folder. Refer to your application server's documentation for
details where this directory resides. (Alternately, you may also copy it to the root of the classpath of each of
your web applications. e.g.: {XTT webapp project root}/src/java.)

2. Run the Make WAR script

In the Package Explorer tab select xtt−examples project.1. 

Right click on the selected xtt−examples project and choose XTT Wizards > Export and WAR.
This action performs two tasks:

It generates the buildfiles (build.xml) for each projectA. 

It runs the make−war target of the Ant script file xttbuild.xml. This Ant script does
two things:

Aggregates the client libraries under the web application root (required for Java Web
Start and Java Plug−in deployments)

◊ 

Builds a distributable WAR file for the web project (created in the
xtt−examples/dist folder).

◊ 

B. 

2. 

Wait until you see the "Finished assembling WAR." message in the Console.3. 

Setup Guide
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With these tasks performed, the xtt−examples application is ready to be deployed.

Deploy the xtt−examples web application

Prepare the deployment as described in the Prepare the demo web application for deployment section.1. 

In the Package Explorer, right−click the project xtt−examples. From the context menu, select Run
as... > Run on Server.

2. 

In the Run on Server window, select a Server runtime XTT Tomcat 5.5.20 which is pre−installed.3. 

Click the Finish button.4. 

To verify that the deployment process was successful, confirm that there were no error messages in
the Output window under the Console tab. The log should indicate that one database connection
(CP1) was initialized and that one object connection (HIBERNATE) was initialized.

5. 
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Test the connection to the xtt−examples web application

Right click on the xtt−examples−client project to bring up project context menu. Select XTT Wizards > 
XTT Table View.

The XTT Table View Wizard is launched (as shown in the next following). The server address
http://localhost:8084/xtt−examples/XTTS appears in the Server Address text field. Press the Get Table
List button.

Select a table, and then a column. If you see table metadata similar to the picture above, the installation
process was successful.

Next steps

You have successfully completed the setup.

Please consult the Developer Guide (in the Eclipse menu under Help > Help Contents > XTT Help >
Product Documentation > Developer Guide) for further instructions on using the xtt−examples application,
creating your own application and exploring the source code and examples.

If you wish to migrate an existing XTT workspace created prior to XTT v 5.7.0, please refer to Appendix B:
Migrating existing workspaces in Eclipse.

Setup Guide
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Appendices

Appendix A: About the XTT Development Platform

The XTT 5.9.4 Development Platform contribute the following items to the Eclipse and NetBeans IDE.

XTT wizards are available in the context menus of the projects.
XTT Table Viewer♦ 
XTT Lock Viewer♦ 
XTT Form Wizard♦ 
XTT Popup Wizard♦ 
XTT Wizard Options♦ 
XTT Object Form Wizard♦ 
XTT Object Popup Wizard♦ 
XTT Object Wizard Options♦ 
XTT XFire Web Services Consumer Wizard♦ 
Open Web Application Home Page (available only in Eclipse)♦ 
Export and WAR (available only in Eclipse)♦ 

1. 

XTT wizards are available in the context menus of the Java editor.
XTT Client Remote Method Code Generation (XTT client projects)♦ 

2. 

XTT Help is added to the Help menu.3. 
Three new tabs for XTT components will appear on the controls Palette; they are: XTT, XTT
Extras, XTT Objects.

4. 

The following libraries are now available to be added to projects:
XTT Client API♦ 
XTT Development♦ 
XTT Client Extras♦ 
XTT Client Remote Class Loader♦ 
XTT Server API♦ 
XTT Server Cache♦ 
XTT Server Hibernate3♦ 
XTT Server Hsql♦ 
XTT Server WebStart♦ 
XTT Server WSDL4J♦ 
XTT Server XFire♦ 

5. 

New XTT workspace and XTT project creation tools available under the New Project menu.
XTT Project Workspace (includes a webapp project, a client project and a common project)
(two types, WTP−based and Ant−based, in Eclipse)

♦ 

XTT Serverside Project♦ 

6. 
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Appendix B: Migrating existing XTT workspaces

This section covers migrating those workspaces created using XTT versions earlier than 5.7.0. For the
purposes of this section, we assume you have an existing workspace called myapp.

Migration for XTT 5.7 and earlier: Overview

Manual migration is required for all XTT 5.7 and earlier projects. The steps for this migration are as follows:

Create a new workspace using XTT 5.9.41. 
Copy the source code of the existing workspace into the new workspace2. 
Resolve any additional dependencies and unsupported API/JAR issues3. 

Section below explains each of these steps in detail.

Migration for XTT 5.7 and earlier: Detailed Instructions

A. Create a new workspace

Backup your existing workspace.1. 
Install the XTT v 5.9.4 Development Framework in your IDE as described in this Setup Guide.2. 
Open the IDE and under the menu New Project..., create a new XTT project workspace called
myapp.

3. 

B. Copy the source code of the existing workspace into the new workspace.

From each project contained in the old myapp workspace, use a file manager to copy the existing
source code to the corresponding project in the new workspace.

Project myapp: The default source code folder is src/java. Copy all existing into the new
workspace.

♦ 

Project myapp: Web files are found in the web folder. Copy any new or modified into the
new workspace.

♦ 

Project myapp−client: The default source code folder is src. Copy all existing into the new
workspace.

♦ 

Project myapp−common: The default source code folder is src. Copy all existing into the
new workspace.

♦ 

In addition, copy whatever other files and archives that you may have placed in other places
in the workspace.

♦ 

Important:
Do not copy into the new workspace any old version of the script file build.xml which is
found in each project root.

♦ 

Do not copy into the new workspace the files contained in the nbproject folder found in
each project root.

♦ 

Do not copy into the new workspace any pre−XTT v 5.7.0 source code in packages
com.itgp.mvc and com.itgp.mvc.view. (Instead replace it with the latest 5.9.4
source from the xtt−examples workspace if you wish.)

♦ 

1. 

Open the new workspace in the IDE in which you installed the latest XTT.2. 
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C. Resolve any additional dependencies and unsupported API issues

Resolve any dependencies on third−party libraries as required.
Duplicate the compiling libraries as they were in the old workspace.

1. 

Refactor all discontinued XTT API usages
A substantial number of changes to the XTT API have occurred between versions 5.3 and 5.4 For a
complete list of API changes, refer to the file ChangeList.html. If you require further assistance
refactoring your XTT workspace, please email us at support@itgp.com for assistance.

2. 
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